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INTRODUCTION
The Child Welfare Services/Case Management System (CWS/CMS) allows counties to create and use county specific templates.  Counties create these templates to meet their individual business needs.  Select data elements from CWS/CMS can populate these templates.  

This CWS/CMS Template Automation Guide provides instructions for creating templates in Microsoft Word 2007, populating select fields from CWS/CMS, and adding templates into CWS/CMS Resource Management for use by county staff.   Template creators should have intermediate knowledge of MS Word 2007 and CWS/CMS Resource Management privilege.
Note:  This guide was created in Word 2007.   Some screenshots may vary from what you see on your screen depending on your computer settings.  The remainder of this guide refers to MS Word 2007 as Word.
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1. SETUP

1.1. Finding Resources to Create Templates 

There are three resources on the CWS/CMS website that you will use to create templates.  These resources can be found at:   http://www.hwcws.cahwnet.gov/guides/default.asp
Once you are on this site, go to Guides|Template Guides.  You will see the following documents:

	CWS/CMS Template Automation Guide
	This is the guide you are referring to now.

	MasterMacro for Word 2007
	This document contains the CreateReport macro that is used to automate your template.  The latest version of this macro is dated 5/1/13 and was developed for CWS/CMS Release 7.0.

	Automation for County User Defined Templates
	This document contains the list of fields from CWS/CMS that can be populated on a template.


Figure 1:  Finding Resources 

1.2. Using Word in Compatibility Mode

Templates and documents for use in the CWS/CMS application will be created in Word 2007; however, they must be saved using the Word 2003 file extensions.  The CWS/CMS application will not allow you to save documents with Word 2007 file extensions.  The file extension differences for Word 2003 and Word 2007 are:   

	
	USE
Word 2003 and Compatibility Mode File Extensions
	DO NOT USE 

Word 2007 File Extensions

	Template
	.dot
	.dotx

.dotm

	Document
	.doc
	.docx


Figure 2:  Using Word Template and Document File Extensions

Word 2007 has the ability to save "down" to Word 2003.  This is referred to as “Compatibility Mode”. Using Word 2007 in compatibility mode allows the user to turn off new features that may not be recognized by Word 2003 so the document remains compatible.

Templates and documents created in Word 2007 for use in CWS/CMS must be in compatibility mode. When a template or document is opened in compatibility mode, the title bar of the document reflects the mode status.
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Figure 3:  Working in Compatibility Mode
To work in compatibility mode, open a document or template (or open a new document or template) and save it as a Word 97-2003 Document or Word 97-2003 Template.   
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Figure 4:  Saving a Document in Compatibility Mode
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Figure 5:  Saving a Template in Compatibility Mode
1.2.1. When Is Compatibility Mode Enabled?
Compatibility mode is enabled in the following situations:

· If you open a file saved in file formats used by previous versions of Word, compatibility mode is enabled.
· If you convert a file from Word 2007 to a previous version using Save As, compatibility mode is enabled.
· If you create a new document based on a .dot template, compatibility mode is enabled.  
· If you set the Word 2007 default to save using the file formats from Word 2003, compatibility mode is enabled.
1.3. Getting Started
Before creating your template, you will need to:

· Display the Developer tab
· Know how to access Legacy Tools
· Set your macro security option
· Know how to create a table
1.3.1. Displaying the Developer Tab

To create forms, you will need to display the Developer tab.  The Developer tab will give you access to tools to create tables and macros.
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Figure 6:  Displaying the Developer Tab
1.3.2. Finding Legacy Form Tools on the Developer Tab
In Word 2007 the Forms toolbar is considered a “legacy tool.”  In order to access it, you have to go to the Developer tab and open Legacy Tools.  Legacy tools will allow you to add controls to your template such as text form fields and check box form fields.  
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Figure 7:  Finding Legacy Tools on the Developer Tab

1.3.3. Setting Macro Security Options
Your template will need a pre-written macro to run in CWS/CMS.  In order for the macro to run, you need to select the correct Word Macro Security setting. 
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Figure 8:  Setting Macro Security

1.3.4. Using Tables and Borders

Most template forms will be created using tables.   Tables will ensure that the template contents (headers, footers, text, signature blocks, etc.) are correctly aligned.  Tables will also allow for the placement of form fields that will populate from CWS/CMS.  
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Figure 9:  Creating a Table
1.3.5. Table Tips
· To see options for working with tables, select the table or a portion of the table and then go to the Layout tab.  There are many table tools available in this tab.

· Make sure that your template has adequate margins so that documents print correctly.  The best way to check for adequate margins is to print the document on the printer(s) that will be used.

Most printers require a minimum width for margin settings because they can’t print all the way to the edge of the page.  If you try to set margins that are too narrow, Word displays the message, “One or more margins are set outside the printable area of the page.”  To prevent text from being cut off, click Fix to automatically increase the margin width.  If you ignore the message and try to print the document as it is, Word displays another message asking whether you want to continue.

The minimum margin settings depend on your printer, printer driver, and paper size.  To learn about the minimum margin settings, check your printer manual.  
· When trying to adjust spacing in a template (whether in a row or column), consider merging cells and/or splitting cells.  
· If you want table borders to appear on the screen and do not want table borders to appear when printing a document:  
· Select the entire table or part of the table, 
· Right click the mouse, 

· Click Borders and Shading… from the menu, and 
· Select None under Setting. 
· To preserve the layout of the form by preventing a row(s) from expanding with text as it is typed:

· Select the row(s), 
· Right click the mouse, 
· Select Table Properties…, 
· Select the Row tab, 
· Check Specify height:, and 
· Select Exactly from the Row height is: dropdown list. 
2. TEMPLATE CREATION
2.1. Creating and Saving the Template
You can start with a blank document and save it as a template, or you can create a template that is based on an existing document or template.
2.1.1. Starting with a Blank Template
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Figure 10:  Creating a Template

2.1.2. Saving the Template
To save the template:
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Figure 11:  Saving the Template
2.2. Adding Content to the Template
If you are starting on a template from scratch, begin by adding a table with many rows and columns.  Remember, a table is being used so that you will be able to align content and controls to look like the original document.  Create your table and type the text for your form.  
2.2.1.   Creating Form Fields
Now that your template is partially created, you will be entering form fields that will populate data from the CWS/CMS application.  
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Figure 12:  Adding Blank Form Fields
2.2.2. Creating Bookmarks
Now that blank text fields have been added to your template, you will need to create bookmarks.  Remember, bookmarks are found in the Automation for County User Defined Templates document mentioned at the beginning of this Guide.
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Figure 13:  Creating a Bookmark
2.2.3. Entering a Long Bookmark
Bookmarks are limited to 20 characters.  Some CWS/CMS bookmarks are too long to fit in the normal bookmark field such as CCServiceComponentType.  Some extra steps will need to be taken to enter these bookmarks.
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    Figure 14:  Entering a Long Bookmark
2.2.4. Copying a Bookmark
Some templates require that the same bookmark be used in several places.  To do this, you will need to copy bookmarks for this purpose.
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Note:  Do not enter a form field where you plan on copying a bookmark.
Figure 15:  Copying a Bookmark

2.2.5. Adding Help Text
Word provides the ability to add Help Text to any form field.  The Help Text will appear in the status bar at the bottom of the screen (when the cursor is on the form field) and/or by having the user press the F1 key.
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Figure 16:  Adding Help Text to a Form Field

By entering information in the Status Bar and/or Help Key (F1) tabs, help text for the form field will be displayed for the end user.   The same options for displaying help text are available under each tab.  They are:
	If You Select:
	Then:

	None
	[image: image13.png]| ‘ O hore




Nothing will display.  Click the OK button.

	AutoText entry
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You can select pre-written text that is included with Word or created by the template developer from the dropdown list.  (This radio button may be disabled if you do not have any auto text in you Auto Text gallery.  Creating text using the AutoText Gallery and Building Blocks is beyond the scope of the guide.)  Then click the OK button.

	Type your own
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You can type your own text in the text box that will display in the status bar.  Then click the OK button.


Figure 17:  Entering Help Text Options
3. TEMPLATE AUTOMATION AND CONFIGURATION
3.1. Automating the Template
To automate your template, the CreateReport macro from the MasterMacro document must be added to the template.  (For a copy of the macro, see the Resources That You Will Need to Create Templates section of this Guide.)

Note:  The current version of the CreateReport macro from the Master Macro document was revised on “05/01/2013 for CWS/CMS Release 7.0”.  This date is noted at the beginning of the document.  
The previous version of the CreateReport macro (“created 04/03/98 and revised 05/09/2007 for CWS_CMS Release 6_0”) will continue to work.  Therefore, existing templates containing the Release 6.0 macro do not have to be updated with the Release 7.0 version of the macro.  

3.1.1. Copying the MasterMacro Into the Template
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To add the CreateReport macro into your template, you will use the Visual Basic editor.
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Figure 18:  Using the Visual Basic Editor
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Figure 19:  Using the Visual Basic Editor – continued

If you do not want to include spell check, place an apostrophe in front of the following line of code:
AskSpellcheck     ' <-- put an apostrophe in front of this line if you don't want the spell check
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Visual Basic Editor
Figure 20:  Pasting the Code into the Visual Basic Editor

If you plan on password protecting the template (see 3.2  Protecting the Template) and are using the Spellcheck macro, type the password between the two quote marks in the code:
passwordTemplate = ""   '<--- IMPORTANT! Password goes here if this template is password protected
 (Note:  Remember this password as you will need to enter it when you protect the template.)
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  Figure 21:  Changing the MasterMacro Name
3.2. Protecting the Template
Once you create the template in Word, you may secure the template so other individuals are unable to delete or edit the template content.  Users will still be able to populate the template and type in text fields, but the “look” (margins, spacing, headings, footers, content controls, etc.) will remain intact.
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Figure 22:  Protecting the Template
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Figure 23:  Enforcing Protection

3.3. Saving and Closing the Template
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Figure 24:  Saving and Closing the Template

3.4. Adding the Template to CWS/CMS
The template is now ready to add to CWS/CMS.  CWS/CMS Template Management is in Resource Management.
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Figure 25:  Adding the Template to CWS/CMS
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Figure 26:  Saving Template in CWS/CMS

To see your added templates, exit CWS/CMS and log back into the application. In some instances, there may be a delay of a few minutes before the template appears.

Test the template. Open a referral or case and try the new template to make sure it is functioning properly. Other users will need to log out of CWS/CMS and re-log in to see the new template. This is not an overnight process.

3.5. Editing Existing CWS/CMS Templates
There may be occasion to edit and update an existing template. Begin by saving the template to be edited in a location other than the default directory.   (Note:  The default directory for CWS/CMS templates is:  C:\CACW\TEMPLATE ).

· To easily locate your template create a folder on your desktop, such as “TEMPLATES TO BE EDITED”.
· Using Microsoft Explorer (not the CWS/CMS Application), find the template to be edited.  Open the template using a right-mouse click and select “Open”.  This opens the actual template.  If you double-click on the template, a document based on the template will be opened.  Make sure that you are working in the .dot (template) file, not the .doc (document) file.    

· Make the desired changes to the template.

3.6. Inactivating a Previous Version of the Template
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Figure 27:  Editing a Template
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Figure 28:  Saving the Edited Template

Now that the previous version of the template is inactivated, the updated template needs to be added to CWS/CMS.  Refer to “Adding the Template to CWS/CMS” of this guide.  
3.7. Adding a Template to CWS/CMS through Server Based Computing (SBC) 
If you access CWS/CMS using a SBC token and the Citrix application (through the internet), there are some different steps to take to add the template to CWS/CMS. 
Create or edit your template using the following sections in this Template Automation Guide:

· Getting Started
· Creating and Saving the Template 
· Adding Content to the Template
· Automating the Template
· Protecting the Template
· Saving the Template (Be sure to note where the template is being saved on your computer's C: drive!)
3.7.1. Adding the Template to CWS/CMS Using SBC

The template is now ready to add to CWS/CMS.  CWS/CMS Template Management is in Resource Management.

 SHAPE  \* MERGEFORMAT 




Figure 29:  Adding a Template to CWS/CMS
The Add As window will appear.  Your screen should look similar to the one below, except that the templates listed may vary.
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Figure 30:  Opening the Add As Window

An important piece of information to know when using SBC and adding a template to CWS/CMS is:
YOUR computer's C: drive will show up as the V: drive in SBC!
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Figure 31:  Locating the Computer’s C: Drive
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Figure 32:  Navigating the C: (V) Drive
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Figure 33:  Locating the Template
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Figure 34:  Saving the Template in CWS/CMS
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Figure 35:  Selecting a Save As Option

To see your added templates, exit CWS/CMS and log back into the application.  In some instances, there may be a delay of a few minutes before the template appears.

Test the template.  Open a referral or case and try the new template to make sure it is functioning properly.  Other users will need to log out of CWS/CMS and re-log in to see the new template.  This is not an overnight process.
4. Questions?
If you have any questions about this guide, please contact your CWS/CMS System Support Consultant (SSC).  Inquiries may be sent to the SSC mailbox at:   
CWS_CustRel@osi.ca.gov
You may also locate your SSC’s contact information on the CWS/CMS website at: 
http://www.hwcws.cahwnet.gov/countyinfo/county_contacts/SSC_list.asp.[image: image29.png]11
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If your Developer tab is not displayed:  


Click the Office Button


Click the Word Options button.  
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In the Word Options dialog box, click Popular.


Check the Show Developer tab in the Ribbon box


Click OK


The Developer tab is now displayed.








To use Legacy Tools:


Click on the Developer tab 


Go to the Controls Group


Click on Legacy Tools


Legacy Tools are now visible
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To set Macro Security:


Click on the Developer tab 


Go to the Code Group


Click on Macro Security to open the Trust Center


Under Macro Settings, click Disable all macros with notification 


Click the OK button


Macro Security is now set.
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To create a table:


Go to the Insert tab


Click Table


Using your mouse, scroll over the number of columns and rows you want and then left click your mouse to place the table onto your template
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Click the Office Button


Click New


Under Templates, click Blank and recent


With Blank document selected, click the Create button
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In the Save As window, click the location where you want to save the template.  (This example is saving the template to the Desktop.) 


Give the template a file name


Select Word 97-2003 Template (*.dot) from the drop down list


Click Save





Click the Office Button and click either:


	Save, Save As, or Local Save…  
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Place the cursor where you want the text to appear on your template.


Go to the Developer tab, Controls group and select Legacy Tools. 


Select the Form Field Shading button � to toggle it on.  When it is on, form fields will appear in grey.


Select the Text Form Field button (ab|)  


This will insert a blank form field    �


Repeat these steps for each form field needed for the template.





Fill-in enabled – selecting this option allows the user to change the value of the populated fields.


Calculate on exit – When this option is enabled, fields and form fields can be updated in a protected form document.





This action opens the Text Form Field Options window.


In the Field settings section, type the bookmark name exactly in the Bookmark: text box (case sensitive)


Check the Fill-in enabled and Calculate on exit check boxes.
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Right-click in a text form field.


Select Properties
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Select the location where you want your bookmark to appear:


Go to the Insert tab


In the Links group


Select Bookmark
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If a bookmark name is showing, remove it by clicking the Delete button.





In the Bookmark name text box, type in the bookmark


Click the Add button
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On your template, select or highlight the text form field/bookmark you want to copy.


Double-click on that text form field/bookmark to open the Text Form Field Options window








Highlight the bookmark name in the Bookmark: field.





Press CTRL+C on your keyboard to copy the bookmark


Select the OK button to close the window








On your template, place the cursor where you want to place the copied field.


Press CTRL+F9 on your keyboard.  The cursor will appear as   �


To paste your bookmark, hold the CTRL+V on your keyboard.  The bookmark name will appear temporarily until the text step  �





Right click in the center of the field and an options window will appear





Select Update Field.  Updating the field will “blank-out” your pasted field.  The bookmark is still present, just not visible.  (To view the field codes, right click on the field.  Select Toggle Field Codes.)
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The Form Field Help Text window has two tabs:


Status Bar 


Help Key (F1)





On your template, select or highlight the text form field/bookmark where you want to add Help Text


Double-click on that text form field/bookmark.


The Text Form Field Options window will appear.








Click the Add Help Text… button and the Form Field Help Text window will appear
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To get to the Visual Basic editor:


Click the Developer tab


Go to the Code group and click the Visual Basic button





1�
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The Visual Basic editor window will open. 


In the Project window, select the name of the project with your template’s name








Open the MasterMacro document that contains the CreateReport macro.  This macro updates the CWS/CMS form fields and spell checks the document.   
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A blank Visual Basic Module window will open.





Go to the Insert tab.


Click on Module. 
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Paste the code into the Visual Basic editor Module window.  
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In the Properties window, highlight the name of the module that you just created.  (If the second window is not visible, select View|Properties Windows)
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Change the name of the Module to CreateReport


The Macro name must be entered exactly as displayed here, for the automation to work correctly:


CreateReport











Go to the File menu and select Close and Return to Microsoft Word





Go to the Developer tab and find the Protect group


Click on the Protect Document down arrow


Under Restrict Reviewing Options, click Restrict Formatting and Editing
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This action will open the Restrict Formatting and Editing window


Under 2. Editing restrictions, check  the box to Allow only this type of editing in the document:





5





4





Under Allow only this type of editing in the document:, select Filling in forms from the dropdown list


Click the Yes, Start Enforcing Protection button
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If desired, enter a password.  Re-enter the password to confirm.


Click the OK button to close the window.  


The Restrict Formatting and Editing window will verify that the document is protected.
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Click the Microsoft Office Button and select Save.   Be sure to note where your template is saved.  You will need to find the template later to save it into CWS/CMS.


Click the Microsoft Office Button and select Close.  The template must be closed before loading it into CWS/CMS.  An error will be received if the template being uploaded is open.
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Open Resource Management


Select the Operations Section


Select Create New Template Management (+ button) to open the Template Management ID page.


Enter the file name in the Template’s DOS Filename Prefix.  The file name is limited to 5 characters.  (If you begin the file name with your county code, all of your county’s templates will be in one area.)


Enter the Title of the template.  The Title is what the user will see in the application.


From the Action menu, select Add Template…
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In the Add As window, locate the template that you previously saved


Click the Open button
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From the File menu select Save to Database


Select one of the Save As Options





Continue Working  - if adding another template


Exit CWS/CMS – if the template creation process is completed
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In the Open window, select the template to be inactivated.


Click the OK button 
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Open Resource Management


Select the Operations Section


Select Open Existing Template Management
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On the Template Management ID page, click the Inactive box.  


Go to the Select File| Save to Database


In the Save Options dialog box, select Continue Working
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Open Resource Management


Select the Operations Section 


Select Create new Template Management (+ button) to open the Template Management ID page.


Enter the file name in the Template’s DOS Filename Prefix.  The file name is limited to 5 characters.  (If you begin the file name with your county code, all of your county’s templates will be in one area.)


Enter the Title of the template.  The Title is what the user will see in the application.


From the Action menu, select Add Template…








2





3





6





1





4





5





In the Look in: dropdown box, select Desktop.


Under Desktop, select C$ on 'Client' (V:).  Note:  Depending on how your computer is setup, you may have a variation of how your C: drive is listed, such as v:[\\Client\C$].  Basically, you are looking for the V: drive.
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Now that you are on your C: drive (the SBC V: drive), navigate to the location of your saved template.


Be sure that your Files of Type: has been set to DOT Files(*.DOT)
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After locating the template, select it.


Click the Open button 
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From the File menu, select Save to Database





Continue Working  - if adding another template


Exit CWS/CMS – if the template creation process is completed.





   Select one of the Save As Options
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