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INTRODUCTION 

The Child Welfare Services/Case Management System (CWS/CMS) allows counties to create and use county 

specific templates.  Counties create these templates to meet their individual business needs.  Select data elements 

from CWS/CMS can populate these templates.   

This CWS/CMS Template Automation Guide provides instructions for creating templates in Microsoft Word 2007, 

populating select fields from CWS/CMS, and adding templates into CWS/CMS Resource Management for use by 

county staff.   Template creators should have intermediate knowledge of MS Word 2007 and CWS/CMS Resource 

Management privilege. 

Note:  This guide was created in Word 2007 and saved in compatibility mode.   Some screenshots may vary from 
what you see on your screen depending on your computer settings.  The remainder of this guide refers to MS Word 
2007 as Word. 
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1. SETUP 

1.1. FINDING RESOURCES TO CREATE TEMPLATES  

There are three resources on the CWS/CMS website that you will use to create templates.  These resources can be 

found at:   http://www.hwcws.cahwnet.gov/guides/default.asp 

Once you are on this site, go to Guides|Template Guides.  You will see the following documents: 

CWS/CMS Template Automation 
Guide 

This is the guide you are referring to now. 

MasterMacro for Word 2007 This document contains the CreateReport macro that is used to automate 
your template.  The latest version of this macro was developed for 
CWS/CMS Release 7.0. 

County Template Data Elements 
and Bookmarks 

This document contains the list of fields from CWS/CMS that can be 
populated on a template. 

Figure 1:  Finding Resources  

1.2. USING WORD IN COMPATIBILITY MODE 

Templates and documents for use in the CWS/CMS application will be created in Word 2007; however, they must 

be saved using the Word 2003 file extensions.  The CWS/CMS application will not allow you to save documents 

with Word 2007 file extensions.  The file extension differences for Word 2003 and Word 2007 are:    

 
USE 

Word 2003 and Compatibility Mode 
File Extensions 

DO NOT USE  
Word 2007 File Extensions 

Template .dot 
.dotx 
.dotm 

Document .doc .docx 

Figure 2:  Using Word Template and Document File Extensions 

Word 2007 has the ability to save "down" to Word 2003.  This is referred to as “Compatibility Mode”. Using Word 
2007 in compatibility mode allows the user to turn off new features that may not be recognized by Word 2003 so 
the document remains compatible. 
 
Templates and documents created in Word 2007 for use in CWS/CMS must be in compatibility mode. When a 
template or document is opened in compatibility mode, the title bar of the document reflects the mode status. 

 

 
Figure 3:  Working in Compatibility Mode 

http://www.hwcws.cahwnet.gov/guides/default.asp
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To work in compatibility mode, open a document or template (or open a new document or template) and save it 

as a: 

1. Word 97-2003 Document, or 
2.  Word 97-2003 Template 

 

 
  

Figure 4:  Saving a Document or Template in Compatibility Mode 

 

1 

2 
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1.2.1. WHEN IS COMPATIBILITY MODE ENABLED? 

Compatibility mode is enabled in the following situations: 

 If you open a file saved in file formats used by previous versions of Word, compatibility mode is enabled. 

 If you convert a file from Word 2007 to a previous version using Save As, compatibility mode is enabled. 

 If you create a new document based on a .dot template, compatibility mode is enabled.   

 If you set the Word 2007 default to save using the file formats from Word 2003, compatibility mode is 
enabled. 
 

1.3. GETTING STARTED 

Before creating your template, you will need to: 

 Display the Developer tab 

 Know how to access Legacy Tools 

 Set your macro security option 

 Know how to create a table 

1.3.1. DISPLAYING THE DEVELOPER TAB 

To create forms, you will need to display the Developer tab.  The Developer tab will give you access to tools to 

create tables and macros. 

   

Figure 5:  Finding Word Options 

If the Developer tab is not displayed:   
1. Click the Office Button 
2. Click the Word Options 

button.   

 

1 

2 
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3. In the Word Options dialog box, click Popular. 
4. Check the Show Developer tab in the Ribbon box 
5. Click OK 

The Developer tab is now displayed. 

 

 

 

 
 
 

 
Figure 6:  Displaying the Developer Tab 

4 

5 

3 
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1.3.2. FINDING LEGACY FORM TOOLS ON THE DEVELOPER TAB 

In Word 2007 the Forms toolbar is considered a “legacy tool.”  In order to access it, you have to go to the 

Developer tab and open Legacy Tools.  Legacy tools will allow you to add controls to your template such as text 

form fields and check box form fields.   

 

Figure 7:  Finding Legacy Tools on the Developer Tab 

To use Legacy Tools: 
1. Click on the Developer tab  
2. Go to the Controls Group 
3. Click on Legacy Tools 
4. Legacy Tools are now visible 

 

2 

3 

4 

1 
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1.3.3. SETTING MACRO SECURITY OPTIONS 

Your template will need a pre-written macro to run in CWS/CMS.  In order for the macro to run, you need to select 

the correct Word Macro Security setting.  

To set Macro Security: 
1. Click on the Developer tab  
2. Go to the Code Group 
3. Click on Macro Security to open the Trust Center 
4. Under Macro Settings, click Disable all macros with notification  
5. Click the OK button 

Macro Security is now set. 
 

 

 

 

Figure 8:  Setting Macro Security 

4 

5 

1 

3 
2 
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1.3.4. USING TABLES AND BORDERS 

Most template forms will be created using tables.   Tables will ensure that the template contents (headers, footers, 

text, signature blocks, etc.) are correctly aligned.  Tables will also allow for the placement of form fields that will 

populate from CWS/CMS.   

 

Figure 9:  Creating a Table 

1.3.5. TABLE TIPS 

 To see options for working with tables, select the table or a portion of the table and then go to the Layout 

tab.  There are many table tools available in this tab. 

 

 Make sure that your template has adequate margins so that documents print correctly.  The best way to 

check for adequate margins is to print the document on the printer(s) that will be used. 

 

Most printers require a minimum width for margin settings because they can’t print all the way to the 

edge of the page.  If you try to set margins that are too narrow, Word displays the message, “One or more 

margins are set outside the printable area of the page.”  To prevent text from being cut off, click Fix to 

automatically increase the margin width.  If you ignore the message and try to print the document as it is, 

Word displays another message asking whether you want to continue. 

  

 The minimum margin settings depend on your printer, printer driver, and paper size.  To learn about the 

minimum margin settings, check your printer manual.   

 

 When trying to adjust spacing in a template (whether in a row or column), consider merging cells and/or 

splitting cells.   

To create a table: 
1. Go to the Insert tab 
2. Click Table 
3. Using your mouse, scroll over the number of columns 

and rows you want and then left click your mouse to 
place the table onto your template 
 

1 

2 

3 
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 If you want table borders to appear on the screen and do not want table borders to appear when printing 

a document:   

o Select the entire table or part of the table,  

o Right click the mouse,  

o Click Borders and Shading… from the menu, and  

o Select None under Setting.  

 

 To preserve the layout of the form by preventing a row(s) from expanding with text as it is typed: 

o Select the row(s),  

o Right click the mouse,  

o Select Table Properties…,  

o Select the Row tab,  

o Check Specify height:, and  

o Select Exactly from the Row height is: dropdown list.  

2. TEMPLATE CREATION 

2.1. CREATING AND SAVING THE TEMPLATE 

You can start with a blank document and save it as a template, or you can create a template that is based on an 

existing document or template.  

2.1.1. STARTING WITH A BLANK TEMPLATE 

 

Figure 10:  Creating a Template

1. Click the Office Button 
2. Click New 
3. Under Templates, click Blank and recent 
4. With Blank document selected, click the 

Create button 

1 

2 

3 

4 
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2.1.2. SAVING THE TEMPLATE 

 

To save the template: 

 
 

Figure 11:  Saving the Template 

2. In the Save As window, click the location where you want to save the 
template.  (This example is saving the template to the Desktop.)  

3. Give the template a file name 
4. Select Word 97-2003 Template from the drop down list 
5. Click Open 

Click the Office Button and click either: 
1.  Save, Save As, or Local Save…   

1 

2 

3 

5 

4 
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2.2. ADDING CONTENT TO THE TEMPLATE 

If you are starting on a template from scratch, begin by adding a table with many rows and columns.  Remember, a 

table is being used so that you will be able to align content and controls to look like the original document.  Create 

your table and type the text for your form.   

2.2.1.   CREATING FORM FIELDS 

Now that your template is partially created, you will be entering form fields that will populate data from the 
CWS/CMS application.   

 

Figure 12:  Adding Blank Form Fields 

 Place the cursor where you want the text to appear on your template. 

 Go to the Developer tab, Controls group and select Legacy Tools.  
1. Select the Form Field Shading button  to toggle it on.  When 

it is on, form fields will appear in grey. 
2. Select the Text Form Field button (ab|)   

 This will insert a blank form field     

 Repeat these steps for each form field needed for the template. 

1 

2 
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2.2.2. CREATING BOOKMARKS 

Now that blank text fields have been added to your template, you will need to create bookmarks.  Remember, 

bookmarks are found in the Automation for County User Defined Templates document mentioned at the beginning 

of this Guide. 

 
Figure 13:  Creating a Bookmark 

Fill-in enabled – selecting this option 
allows the user to change the value of 
the populated fields. 

Calculate on exit – When this option is 
enabled, fields and form fields can be 
updated in a protected form 
document. 

This action opens the Text Form Field 

Options window. 

2. In the Field settings section, type the 
bookmark name exactly in the 
Bookmark: text box (case sensitive) 

3. Check the Fill-in enabled and 
Calculate on exit check boxes. 

1. Right-click in a text form field. 
Select Properties 

1 

2 

3 
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2.2.3. COPYING A BOOKMARK 

Some templates require that the same bookmark be used in several places.  To do this, you will need to copy 

bookmarks for this purpose. 

Note:  Do not enter a form field where you plan on copying a bookmark. 

 

 

Figure 14:  Copying a Bookmark 

2. Right click in the center of the field 
and an options window will appear 

3. Select Update Field.  Updating the 
field will “blank-out” your pasted 
field.  The bookmark is still present, 
just not visible.  (To view the field 
codes, right click on the field.  Select 
Toggle Field Codes.) 

3 
2 

1. Highlight the bookmark name in the 
Bookmark: field. 

 Press CTRL+C on your keyboard to copy 
the bookmark 

 Select the OK button to close the window 
 

 On your template, place the cursor where you want to place the copied field. 

 Press CTRL+F9 on your keyboard.  The cursor will appear as    

 To paste your bookmark, hold the CTRL+V on your keyboard.  The bookmark name will appear 

temporarily until the text step   

 On your template, select or highlight the 
text form field/bookmark you want to copy. 

 Double-click on that text form 
field/bookmark to open the Text Form 
Field Options window 
 

1 
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2.2.4. ADDING HELP TEXT 

Word provides the ability to add Help Text to any form field.  The Help Text will appear in the status bar at the 

bottom of the screen (when the cursor is on the form field) and/or by having the user press the F1 key. 

 

 

Figure 15:  Adding Help Text to a Form Field 

2. The Form Field Help Text window has 
two tabs: 

 Status Bar  

 Help Key (F1) 

2 

 On your template, select or highlight the 
text form field/bookmark where you want 
to add Help Text 

 Double-click on that text form 
field/bookmark. 

 The Text Form Field Options window will 
appear. 
 

1. Click the Add Help Text… button 
and the Form Field Help Text 
window will appear 

1 
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By entering information in the Status Bar and/or Help Key (F1) tabs, help text for the form field will be displayed 

for the end user.   The same options for displaying help text are available under each tab.  They are: 

If You Select: Then: 

None  

Nothing will display.  Click the OK button. 

AutoText 

entry  

You can select pre-written text that is included with Word or created by the template 

developer from the dropdown list.  (This radio button may be disabled if you do not 

have any auto text in you Auto Text gallery.  Creating text using the AutoText Gallery 

and Building Blocks is beyond the scope of the guide.)  Then click the OK button. 

Type your 

own  

You can type your own text in the text box that will display in the status bar.  Then 

click the OK button. 

Figure 16:  Entering Help Text Options 
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3. TEMPLATE AUTOMATION AND CONFIGURATION 

3.1. AUTOMATING THE TEMPLATE 

To automate your template, the CreateReport macro from the MasterMacro document must be added to the 

template.  (For a copy of the macro, see the Resources That You Will Need to Create Templates section of this 

Guide.) 

Note:  The current version of the CreateReport macro from the Master Macro document was revised for CWS/CMS 

Release 7.0”.   

The previous version of the CreateReport macro (“created 04/03/98 and revised 05/09/2007 for CWS_CMS Release 

6_0”) will continue to work.  Therefore, existing templates containing the Release 6.0 macro do not have to be 

updated with the Release 7.0 version of the macro.   

3.1.1. COPYING THE MASTERMACRO INTO THE TEMPLATE 

To add the CreateReport macro into your template, you will use the Visual Basic editor. 

 

Figure 17:  Using the Visual Basic Editor 

 

To get to the Visual Basic editor: 
1. Click the Developer tab 
2. Go to the Code group and click the Visual Basic button 

The Visual Basic editor 
window will open.  

3. In the Project 
window, select the 
name of the 
project with your 
template’s name 

 

2 

1 

3 
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Figure 18:  Using the Visual Basic Editor –continued 

If you do not want to include spell check, place an apostrophe in front of the following line of code: 

AskSpellcheck     ' <-- put an apostrophe in front of this line if you don't want 

the spell check  

6. A blank Visual Basic 

Module window will 

open. 

4. Go to the Insert tab. 
5. Click on Module.  

5 

4 

6 

7. Open the MasterMacro document 

that contains the CreateReport 

macro.  This macro updates the 

CWS/CMS form fields and spell 

checks the document.    

 

 

7 
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Figure 19:  Pasting the Code into the Visual Basic Editor 

If you plan on password protecting the template (see 3.2  Protecting the Template) and are using the Spellcheck 

macro, type the password between the two quote marks in the code: 

passwordTemplate = ""   '<--- IMPORTANT! Password goes here if this template is 

password protected 

 (Note:  Remember this password as you will need to enter it when you protect the template.) 

   

8. Copy and paste the 

code into the Visual 

Basic editor Module 

window.   

8 
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  Figure 20:  Changing the MasterMacro Name 

10. Change the name of the 
Module to CreateReport 

The Macro name must be 
entered exactly as displayed 
here, for the automation to 
work correctly: 

CreateReport 

Go to the File menu and 

select Close and Return to 

Microsoft Word 

 

 

9. In the Properties window, 

highlight the name of the 

module that you just created.  (If 

this window is not visible, select 

View|Properties Windows 

9 
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3.2. PROTECTING THE TEMPLATE 

Once you create the template in Word, you may secure the template so other individuals are unable to delete or 

edit the template content.  Users will still be able to populate the template and type in text fields, but the “look” 

(margins, spacing, headings, footers, content controls, etc.) will remain intact. 

 

 

 

 

 

 

 

Figure 21:  Protecting the Template 

 

3. This action will open the Restrict 
Formatting and Editing window 

4. Under 2. Editing restrictions, check  the 
box to Allow only this type of editing in 
the document: 

4 

3 

1. Go to the Developer tab and find the 
Protect group 

2. Click on the Protect Document button 

1 

2 

5. Under Allow only this type of editing 
in the document:, select Filling in 
forms from the dropdown list 

6. Click the Yes, Start Enforcing 
Protection button 

6 

5 



 TEMPLATE AUTOMATION GUIDE   

 
 

25 CWS/CMS Office 
User Resource Services Team 

September 2013 
fv 1.0 

 

 

 

 

Figure 22:  Enforcing Protection 

3.3. SAVING AND CLOSING THE TEMPLATE 

 

Figure 23:  Saving and Closing the Template

1. Click the Microsoft Office Button and 
select Save.   Be sure to note where your 
template is saved.  You will need to find 
the template later to save it into 
CWS/CMS. 

2. Click the Microsoft Office Button and 
select Close.  The template must be 
closed before loading it into CWS/CMS.  
An error will be received if the template 
being uploaded is open. 

1 

2 

9 

7. If desired, enter a password.  Re-
enter the password to confirm. 

8. Click the OK button to close the 
window.   

9. The Restrict Formatting and 
Editing window will verify that the 
document is protected. 

7 

8 
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3.4. ADDING THE TEMPLATE TO CWS/CMS 

The template is now ready to add to CWS/CMS.  CWS/CMS Template Management is in Resource Management. 

 

Figure 24:  Adding the Template to CWS/CMS 

1 

1. Open Resource Management 
2. Select the Operations Section  
3. Select Create New Template Management (+ 

button) to open the Template Management ID page. 
4. Enter the file name in the Template’s DOS Filename 

Prefix.  The file name is limited to 5 characters.  (If 
you begin the file name with your county code, all of 
your county’s templates will be in one area.) 

5. Enter the Title of the template.  The Title is what the 
user will see in the application. 

6. From the Action menu, select Add Template… 
 

3 
2 

4 

5 

6 
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Figure 25:  Saving Template in CWS/CMS 

To see your added templates, exit CWS/CMS and log back into the application. In some instances, there may be a 

delay of a few minutes before the template appears. 

Test the template. Open a referral or case and try the new template to make sure it is functioning properly. Other 

users will need to log out of CWS/CMS and re-log in to see the new template. This is not an overnight process. 

7. In the Add As 
window, locate the 
template that you 
previously saved 

8. Click the Open 

button 

 

9. From the File menu select Save to Database 
10. Select one of the Save As Options 

 Continue Working  - if adding another 
template 

 Exit CWS/CMS – if the template creation 
process is completed 

7 

8 

9 
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3.5. EDITING EXISTING CWS/CMS TEMPLATES 

There may be occasion to edit and update an existing template. Begin by saving the template to be edited in a 

location other than the default directory.   (Note:  The default directory for CWS/CMS templates is:  

C:\CACW\TEMPLATE ). 

 To easily locate your template create a folder on your desktop, such as “TEMPLATES TO BE EDITED”. 

 Using Microsoft Explorer (not the CWS/CMS Application), find the template to be edited.  Open the template 
using a right-mouse click and select “Open”.  This opens the actual template.  If you double-click on the 
template, a document based on the template will be opened.  Make sure that you are working in the .dot 
(template) file, not the .doc (document) file.     

 Make the desired changes to the template. 

3.6. INACTIVATING A PREVIOUS VERSION OF THE TEMPLATE 

  

Figure 26:  Editing a Template 

1. Open Resource Management 
2. Select the Operations Section 
3. Select Open Existing Template 

Management 

1 

3 

2 

4. In the Open window, 
select the template 
to be inactivated. 

5. Click the OK button  
 

4 

5 
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Figure 27:  Saving the Edited Template 

Now that the previous version of the template is inactivated, the updated template needs to be added to 

CWS/CMS.  Refer to “Adding the Template to CWS/CMS” of this guide 

6. On the Template 
Management ID page, 
click the Inactive box.   

7. Go to Select File| Save to 
Database 

8. In the Save Options dialog 
box, select Continue 
Working 6 

7 

8 
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3.7. ADDING A TEMPLATE TO CWS/CMS THROUGH SERVER BASED COMPUTING (SBC)  

If you access CWS/CMS using a SBC token and the Citrix application (through the internet), there are some 

different steps to take to add the template to CWS/CMS.  

Create or edit your template using the following sections in this Template Automation Guide: 

 Getting Started 

 Creating and Saving the Template  

 Adding Content to the Template 

 Automating the Template 

 Protecting the Template 

 Saving the Template  
 

(Note:  Be sure to note where the template is being saved on your computer's C: drive!  In the following example for 
SBC, the template has been saved to the Desktop.) 
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3.7.1. ADDING THE TEMPLATE TO CWS/CMS USING SBC 

 
The template is now ready to add to CWS/CMS.  CWS/CMS Template Management is in Resource Management. 

 

 Figure 28:  Adding a Template to CWS/CMS Using SBC 

1 

1. Open Resource Management 
2. Select the Operations Section  
3. Select Create New Template Management (+ 

button) to open the Template Management ID page. 
4. Enter the file name in the Template’s DOS Filename 

Prefix.  The file name is limited to 5 characters.  (If 
you begin the file name with your county code, all of 
your county’s templates will be in one area.) 

5. Enter the Title of the template.  The Title is what the 
user will see in the application. 

6. From the Action menu, select Add Template… 
 

3 
2 

4 

5 

6 
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The Add As window will appear.  Your screen should look similar to the one below, except that the templates listed 

may vary.  Your objective now is to navigate through your C drive to find the template that you created that you 

want to add into CWS/CMS.    

It is important to note that when using SBC and adding a template to CWS/CMS: 

YOUR COMPUTER'S C: DRIVE WILL SHOW UP AS THE V: DRIVE IN SBC! 

   

         Figure 29:  Finding the Created Template on Your Computer Using SBC 

 

                             Figure 30:  Citrix Client File Security 

You may receive the Citrix Client File 
Security dialog box.   
8. When asked, “What access do you 

want to grant?” - select the Full 
Access radio button.   

9. When asked, “Do you want to be 
asked again?”- select the Never 
ask me again radio button.   

10. Click the OK button. 

8 

9 

10 

7. Under Favorite Links, click 

Computer. 

 

7 
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Figure 31:  Finding Your Computer's C: Drive Using SBC 

 

 

 

 

 

 

 

Figure 32: Navigating to the Template Using SBC 

11. Under Network Location, look 
for the V: drive.  In this 
example, the V drive is shown 
as C$(\\Client)(V:) .  Note:  
Depending on how your 
computer is setup, you may 
have a variation of the drives 
shown and how your C: drive is 
listed, such as v:[\\Client\C$] , 
Network Drive (V:), or C$ on 
'Client' (V:).  Basically, you are 
looking for the V: drive. 

 

11 

12. You will now navigate through your folders to 

find your template.  (In this example, the ABC 

Template was saved to the computer’s Users 

folder.  Further navigation was required 

(Users>lan4test>Desktop) to get to the template. 
12 
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                        Figure 33:  Open the Template In SBC 

 

 

Figure 34:  Save Template to Database 

 

               Figure 35:  Selecting a Save As Option 

To see your added templates, exit CWS/CMS and log back into the application.  In some instances, there may be a 

delay of a few minutes before the template appears. 

Test the template.  Open a referral or case and try the new template to make sure it is functioning properly.  Other 

users will need to log out of CWS/CMS and re-log in to see the new template.  This is not an overnight process. 

 Continue Working  - if adding another 
template 

 Exit CWS/CMS – if the template creation 
process is completed. 

16.    Select one of the Save As Options 

16 

15. From the File menu, select 
Save to Database 

15 

13. After navigating to the template, select it. 
14. Click the Open button 
 
Your template has now been added to CWS/CMS. 

13 

14 
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4. QUESTIONS? 

 
If you have any questions about this guide, please contact your CWS/CMS System Support Consultant (SSC).  
Inquiries may be sent to the SSC mailbox at:    

CWS_CustRel@osi.ca.gov 

You can locate your SSC’s contact information on the CWS/CMS website at:  

http://www.hwcws.cahwnet.gov/countyinfo/county_contacts/SSC_list.asp. 

mailto:CWS_CustRel@osi.ca.gov
http://www.hwcws.cahwnet.gov/countyinfo/county_contacts/SSC_list.asp

